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Introduction

This document and the accompanying map template were created to make the job of creating a 
certification map easier and faster.  For many course measurers, especially new measurers, creating the 
certification map is the least desirable task associated with measuring a course for certification.  It is  
our hope that providing a map template with what we hope is easy to follow instructions, will make the 
map creation task easier for you.

The software chosen for this purpose is OpenOffice.  OpenOffice was chosen  because 1) it is free, 2) it 
is relatively easy to learn, 3) it runs on both Windows and Mac machines with a nearly identical user 
interface, and 4) it has all the tools necessary for the job.

It is important to understand that you are not required to use this template to create your certification  
map.  If you have another method you like to use, or plan to use, to create your maps, you are welcome 
to do that.  If you do that though, you will still need to include on your map all the required elements as 
described in the course procedures manual on the USATF/RRTC website.
http://www.usatf.org/events/courses/certification/manual/

Acknowledgement

None of the ideas presented in this document for how to create the required map elements with a 
computer application are mine.  My first few maps took hours to produce and the result, while 
functional, was pretty ugly.  I learned almost all the tips and tricks I now use for making maps from 
fellow measurers posting their ideas on on the Road Course Measurement Bulletin Board 
(http://  measure.infopop.cc/eve/forums  ).

Downloading OpenOffice

The OpenOffice application can be downloaded from the following website.
http://www.openoffice.org/

Once you have it downloaded the application, double-click on the file that is downloaded and it will  
lead you through the installation process.

After you have used OpenOffice for a while, if you think it is the greatest software ever created, or just 
pretty darn good, you might consider making a donation to the cause.  You can do that on their donation 
page at
http://contributing.openoffice.org/donate.html

Required elements and features of a course certification map

A good description of how to draw and course map and all the requirements of a course map is given in 
the online procedures manual at the USATF / RRTC (Road Running Technical Council) website.
http://www.usatf.org/events/courses/certification/manual/

http://www.usatf.org/events/courses/certification/manual/
http://www.usatf.org/events/courses/certification/manual/
http://contributing.openoffice.org/donate.html
http://www.openoffice.org/
http://www.openoffice.org/


You can go directly to the course map section with the following link.
http://www.usatf.org/events/courses/certification/manual/course-maps.asp

Several of the requirements are set up for you with the map template that this document describes,  
including the listing of the race name, city and state, showing the direction of north, the 3/8” margins,  
and including only black & white elements.  However, you should go ahead and read the whole 
description of course maps on the USATF/RRTC website just to understand all of the requirements. 
Also, at the end of the section there are several examples of course maps given.

Downloading the map template and instructions

The map template can be downloaded at the following link.
http://www.dukerdog.com/USATF/Map_template/Map_template.otg

The instructions file (the file you are reading) in pdf format can be downloaded from
http://www.dukerdog.com/USATF/Map_template/Map_template_instructions.pdf

And an example of a completed map in OpenOffice format (although not a real one that has actually 
been certified) can be downloaded from 
http://www.dukerdog.com/USATF/Map_template/Map_example.odg

After you download the map template put it in a folder where you will keep it from now on.  When you 
want to create a new map just double-click on this template file, or start up OpenOffice first and go to 
File>Open...  OpenOffice will open the file and give it a generic name.  If later you select File>Save it  
will ask you for a name to save under rather than overwriting the template file.  This helps prevent you 
from mistakenly changing the template file by forgetting to create a new file for your map.

Overview of the map template

The idea of the map template is that you use it as the starting point for every course map you create.  
This is done by first opening the map template file from within OpenOffice, and then immediately 
saving it under a different name.  By doing this the original map template will remain unchanged and 
will be available as the starting point for your next map.  If you forget to do this until after you make 
changes to the template and simply hit Save, you will no longer have the template on your computer in  
its original state.  In that case though, you can always download it again from the website, as described 
in the downloading section above.

The figure on the next page shows a screen shot of the map template page with the different elements 
numbered for reference.  A description of each element follows.

http://www.dukerdog.com/USATF/Map_template/Map_example.odg
http://www.dukerdog.com/USATF/Map_template/Map_template_instructions.pdf
http://www.dukerdog.com/USATF/Map_template/Map_template.otg
http://www.usatf.org/events/courses/certification/manual/course-maps.asp


Headings: Every map will need the race name and race location, city and state, prominently displayed.  
You should check with your course certifier to see if he will accept course maps in OpenOffice format. 
If he/she will, you can leave the course certification number heading and effective date heading as they 
are, and he/she will be able to change them as necessary.  If your certifier does not accept OpenOffice 
format maps you will need to delete these two headings, as he/she will have their own method for 
adding this information.

North direction arrow:  This is a required on your map.

Roads: These are included on the template so you can modify them to fit your map rather than having 
to create them from nothing.  There are three different types shown, and they will be described in a 
later section.



Course route: Same as the Roads, they are put on the template so they can be modified to fit your map. 
Examples of two different types of lines are shown.  They will be described in detail in a later section.

Course route direction arrows: These are used to show the direction the runners will be following.

Mile marks: These will be placed at the approximate locations of the mile marks along the course 
route.

Mile mark descriptions:  These are descriptions relative to permanent landmarks of the locations of 
the start, finish, all turn-arounds, and mile/kilometer marks.  These descriptions are required for the 
start, finish, and turn-arounds, either in words or on the map itself, or both.  Mile mark descriptions are 
optional, but are strongly recommended.  For maps of longer courses, like half or full marathons, it is 
permissible to include the list of mile mark descriptions on a separate page.

Blowup detail:  These are used to show the details of the start, finish, etc.

Labels:  Street names, landmark descriptions, etc.

Understanding layers

The concept of layers is useful for making all kinds of drawing, including certification maps.  Layers 
are a way of separating the components of your map into different groups.  This helps organize the 
map, and also makes it possible to work on the different parts of the map without having to worry about 
messing up other parts.  This will become clearer in the later sections of these instructions.

The first thing you should do when you open up the map template in OpenOffice is to take a look at the 
different layers that have been set up for the map.  Unfortunately, when the OpenOffice Draw program 
starts up with the map template, it doesn't show you all the layers.   To see them all you will need to 
move the little vertical bar at the bottom of the Draw window (see figure below).

To move the bar, click on it with the mouse (left button on the PC) and hold down the button while 
moving to the right (known as dragging).  This will show the tabs of all the different layers of the map 
(see figure below).



The first three layers on the left are part of every Draw document (Layout, Controls, Dimension Lines). 
They aren't very useful for a map document, but they can't be renamed and they can't be deleted, so 
we're stuck with them.  But we don't use them in the map template, so you can just ignore them.

The other seven layers are part of the map, and “contain” different components of the map.  This is 
pretty self-explanatory by the names of the layers, but further explanation will be given in subsequent 
sections.  For right now the important this to understand is how the different properties assigned to each 
layer affect how you work.

Each layer in OpenOffice Draw has three properties: Visible, Printable, and Locked.  You can see the 
status of the each of the properties of a layer by right-clicking the layer tab (<control> click on the 
Mac), and then selecting Modify Layer in the menu that pops up.  This will bring up the window shown 
below.

Visible: If checked, the objects contained in that layer will be seen.  If not, they won't.  Also, if you 
print the document, any objects in a layer that is not visible will not be printed.
Printable: If checked, then the objects in that layer will be printed if they are also visible.  If not 



checked they will never be printed, even if they are visible on the screen.
Locked: If checked, then the objects on the layer cannot be changed, and in fact cannot even be 
selected.  It is often useful to make a layer Locked so that you can protect the objects on the layer from 
being changed by mistake.

The status of the layers in the map template are as follows:

Layout, Controls, Dimension Lines: Not Visible, Not Printable, Locked.
Background map: Visible, Not Printable, Locked.
All other layers: Visible, Printable, Not locked.

As can be seen from above, all the layers that you'll be working with start out as not locked when you 
first open the map template.  This is done so that if you don't want to bother with dealing with layers 
you can just ignore them.  All the objects will be selectable and changeable regardless of which layer is  
currently active.  In order to use a background map though, you will need to bother with layers for that. 
But detailed step-by-step instructions will be given in the next section for setting up and using a 
background map.  Once you finish using the background map and make it invisible, you can ignore the 
layers if you choose.

If you do choose to take advantage of working with layers, you'll need to make sure that any new 
objects you create go onto the correct layer.  The  recommended practice for doing this is to change the 
status of a layers to Locked, except for the one you are currently working on.  When you change from 
working on one layer to working on another one, make the previous one Locked before starting work 
on the new one.

One final note about layers is that it is inevitable you will at some time create an object in one layer  
that really belongs in a different layer.  Fortunately, there is an easy way to move those objects to their  
correct layer.  First make sure that the layer where objects are (layer A, say) and the layer where you 
want to move them (layer B, say) are both Not locked.  Make layer B active and select all the objects  
you want to move.  Then select Edit>Cut and then Edit>Paste.  The objects have now been moved to 
layer B.  You can check this by locking layer B and then verifying that you can no longer select the 
objects.

Background map

Certification maps must be black and white only, meaning not only that no color is allowed, but also 
that no gray is allowed either.  First time map makers will often make the mistake of copying a map 
they have created on one of the online mapping tools such as Google Maps or Mapmyrun.com.  But 
because the maps created with those tools always contain color or grays, they cannot be used on a 
certification map in their raw form.  But they are still very useful as a “background map” for your 
certification map.

The idea of a background map is that  you copy a map of the area of your course that you’ve created in 
an online program, and then paste it to the “Background map” layer of your certification map.  You can 
then use it as a guide when you are creating the roads with the OpenOffice drawing tools (discussed in 
the next section).  Once you have all your roads completed, you change the status of the Background 
map layer to Not Visible.  As an alternative, you could just delete the background map image after you 
are done making your roads.  But the advantage of simply making it invisible by using layers is that 



you can very easily bring it back later if you need it.

Capturing a background map image on the Macintosh: The Macintosh operating system provides a 
utility called Grab for this purpose.  You can find Grab in the Utilities folder of the Applications folder.  
Drag its icon from that folder to the Dock, and then you can always start it up by clicking its icon on 
the Dock.  After you start up Grab select Capture>Selection and create a rectangular region you want 
by dragging the mouse over it.  This will open an image file within Grab that you can then save.  Then, 
back in OpenOffice, make sure you are on the Background map layer (and it is Not locked) and select 
Insert>Picture>From file... and find and select the image file you just saved.

Capturing a background map image on a Windows PC: To capture the entire computer screen or the 
active window on a Windows PC computer, use the Prtscr key on your keyboard.  There is detailed 
instructions for this at
http://graphicssoft.about.com/cs/general/ht/winscreenshot.htm

After you have done the print screen thing, go back to the map template OpenOffice file and make the 
active layer Background map (make sure it is Not locked).  Then select Edit>Paste.  If there is more in 
the image than you really want you can “crop” the image to include only the part you do want.  Right 
click on the image and select Crop...  You can then cut off, or crop, from the left, right, top, or bottom 
of the image.  You can also resize the map by selecting it and then dragging one of the corners.

Once you have the background map the way you want it, select the map and then right-click (<control> 
click on the Mac) and select Arrange>Move to Back.  Finally, right-click on the Background map layer 
tab, and select Modify layer. In the window that pops up, select the Locked checkbox.  This will 
prevent the map image from being selected, moved, etc., while you are using it to create your roads 
(described in the next section).  After you are finished making your roads you should right-click again 
on the Background map layer tab and uncheck the Visible box.

Creating roads

In this section we will present a clever method for creating a very nice looking grid of roads.  If you 
have every tried to create a grid of roads with a drawing program by creating each edge of the road 
independently, and then manipulating the intersections one-by-one until they look ok, you will quickly 
convert to this method.

A quick overview of the method is given first and then that will be followed by a more detailed 
description.

1) Make sure you are in the Roads layer and it is Not locked.
2) Using the line tool and the curve tool, and with the background map as your  guide, draw the 

network or roads necessary for your map.
3) Select all of the lines and curves that make up the roads of your map.
4) Increase the line thickness to 0.20”.
5) Select Edit>Copy and then Edit>Paste. (This will create copies of all your roads and make the 

copies the currently selected items)
6) Change the color of these new road copies to white.
7) Decrease the line thickness of these new road copies to 0.12”.

Like magic, you now have a very nice looking set of roads, complete with very clean looking 

http://graphicssoft.about.com/cs/general/ht/winscreenshot.htm


intersections.  If you are a new measurer who has never tried to do this manually, you may not be all 
that impressed.  But if you are someone like me, who has spent hours drawing each edge of every road, 
and  then going back to clean up each intersection one-by-one,  well, let’s just say the invention of 
sliced bread comes to mind.

The above brief description of road creation does leave out a number of details that you may have 
difficulty with, so they will now be covered.

The best way to start creating your roads is to modify the ones that already exist in the map template.  
To do this click on the center of one of the roads, the white portion,  and then hit the delete key.  Repeat 
this for all the other roads.  For the straight roads (Main Street in the template) on your map select the 
straight road example given by clicking on it, and then move the endpoints to the appropriate positions.  
If you have additional straight roads just copy and paste until you have as many as you need.

You might find that when you drag an endpoint or intermediate point somewhere and then release the 
mouse, the point jumps to a close-by location.  If this happens your preferences are probably set to 
“snap-to-grid.”  You can change this by selecting View>Grid>Snap to Grid.  If you go back to 
View>Grid the little checkmark next to Snap to Grid should have disappeared, and endpoints and 
intermediate points should now stay where you put them.

Another type of line that can be used is shown by Blues Street.  This is a multi-segment straight line. 
Select the center of Blues Street and then his delete to remove the white part.  Now click on the black 
street and you will see that there is an intermediate point in the middle of the line at the kink.  You can 
move this point as well as the endpoints.  Using the edit toolbar (described below) you can add and 
delete intermediate points as well.

The curved roads are a little trickier.  Begin by deleting the white portions of the roads as before.  Then 
click on the black portion of  one of the roads.  You will see that in addition to the endpoints of the 
curved road, there are intermediate points.  You can change the shape of the road by dragging any of 
these endpoints or intermediate points to a new location.  When you click on an intermediate point you 
will notice that there are other points that appear, connected to the intermediate point by dotted lines.  
Moving these points also modifies the shape of the curve, but in a different way, by changing the 
curvature near the associated intermediate point.  The best way to understand how this changes the 
shape of the curve is to just play around with it for a while.

Now click on the edit points icon in the edit toolbar, as shown in the figure below.



After clicking on the edit points icon the edit points toolbar should appear (you might have to click it  
twice, but sometimes the edit points toolbar shows up when you just click on the curve).  On the edit 
points toolbar, hovering over the different icons will display text explaining what they do.  There is one 
to add intermediate points and one to eliminate them.  By adding intermediate points to the example  
road you will be able to create a very long curvy road with a single curve object.

After you have created all the roads you need and put them in the correct place (with guidance from 
your background map), it’s time to add the white interiors to make road edges.  Select all of the black 
roads by clicking on them one at a time while holding down the Shift key.  Once you have them all 
selected hit Edit>Copy and then Edit>Paste.  Then change the color to white and change the thickness 
to 0.16”.  The two icons to select in order to do these operations is shown in the figure below.

After you have created all of your roads you may want to make some roads wider and some thinner, but 
keep in mind any road on your course will need to be wide enough to include a course route line in the 
white portion.  To make a road wider, select the edge of the road and increase its thickness.  This will 
make the black portion only wider.  Then select the middle of the road and increase its thickness.

Once concept you should understand that we used to create these roads is object stacking.  When we 
created the white portion of the road we placed it in front of the black portion.  Because of that, you 
don’t see the middle black portion of the road.  You can change the stacking order of the objects by 
selecting an object and then selecting the arrange icon on the standard toolbar, as shown in the figure 



below.  Also shown in this figure is the zooming control for zooming the view of your map in and out.

You can then choose to move the selected object to the front of the stack or the bottom of the stack.  If 
you find that some of the black portions of the roads are showing up in front of some road white 
portion, just select that road and move it to the bottom of the stack.

Drawing the course route

Once you have mastered the art of creating roads, creating the course route is pretty simple.  One of the 
course route examples on the template map is a curve object with an arrow at the end.  The other is a 
multi-segment line with an arrow at the end.

For the curve example, just put the endpoint without the arrowhead at your start line, and the endpoint 
with the arrowhead in the middle of the first straight section of your course after some curves.  Then 
add and move any intermediate points you need to make all the turns in between.  Next, select the 
curve and hit copy and paste.  Move the endpoint without the arrow of your new curve to the arrow tip 
of your first curve.  Put the arrow endpoint of the new curve in the middle of the next straight section of 
your course, and add and modify  intermediate points to follow the curves of your course.  Repeat this 
process of adding new curves until you get to the finish line of your course.

If you want to use the multi-segment line instead, just follow the same procedure as for the curve, but 
then you don't need to adjust the curvature, because of course, there isn't any.

After completing this process you should have a nice, smooth looking path of your course route, 
complete with arrows showing the direction the runner will be going.  However, you might want to add 
a few arrows in other places on the course, and for this purpose some arrowheads have been included 
on the map template.

Single-line map alternative

An alternative to creating roads with the course route in between the road edges is to just eliminate the 
roads altogether and just use the course route as the only description of the course.  This is often called 
a single-line map.  An example is shown in the downloadable file map_example_singleline.odg.  Note 
that in this type of map it is probably best to change the race course line to a continuous, rather than 



dashed, line style.  Also bear in mind that one disadvantage of this type of map is that there is no 
natural way to show cross streets, which are often very helpful to people trying to understand your 
map.

Drawing blowup details

You are required to describe the location of the start, finish, and any turn-arounds on your course 
relative to permanent landmarks.  A good way to do that is to create a detailed map of the area local to  
the start, finish, or turn-around, and show the distances to the landmarks.  In the map template all the 
objects in the example detailed blowup have been created on the same Details layer, even though they 
contain many different types of objects, roads, labels, etc.  The reason for this is that it makes the entire 
detailed map blowup easy to move.  This is often necessary, as it is sometimes difficult to find a place 
on the map where there is room for it.

In order to move an entire detail blowup make sure all the other layers are Locked and the Details layer  
is Not locked.  Then click and drag over all the objects in the detail blowup.  This will select all of its  
objects.  Now click on one of the objects and drag to a new location.  This will move the entire blowup 
to a new location.

Labels

You will need to include street names, measurement to landmarks, and possibly other comments on 
your map, and you do this with the text tool.  You can create a new text box by clicking on the big “T” 
in the toolbar at the bottom of the window.  But it is just as easy to select one of the text boxes in the 
map template and copy and paste.  When the text box is selected all of the formatting options that  
appear at the top of the window are for the “box,” not the text.  If you change from “invisible” to one of 
the line options, it will create a rectangular outline around your text, and you can then change the color  
of it, etc.  To rotate the text box click on the circular arrow icon in the toolbar at the bottom on the right  
side.  Clicking and dragging on one of the red points of the textbox rotates it.

In order to edit the actual text, double-click on the textbox.  Now a straight-line text cursor appears.  
With this you can select and delete text or place the position to add more text.  When you are editing 
text the toolbar at the top of the window changes to text formatting icons.  Here you can change the 
font type, font size, color, etc. of your text.

Submitting your map

If your state certifier will accept a map in OpenOffice format (check with him/her) you can just save 
your file and send it to him/her.  If not, you will need to export the map to PDF format before sending 
it.  However, before exporting to PDF format you should remove the certification # and Effective Dates 
headings, since your certifier will have his/her own way of adding those to your map.

To export in PDF format select File>Export PDF...  This will bring up a window with lots of options. 
Don't worry about changing any of them.  Just hit Export and then give it a name to save it under.



Getting additional help

At the top of the OpenOffice window there is a Help menu.  In this menu select OpenOffice Help.  I 
have found this help utility to be better than average.

But many of your questions may be related directly to making certification maps, and it might be more 
difficult, or impossible, to find the answers to those questions in OpenOffice Help.  Instead you should 
check the Race Course Measurement Bulletin Board at

http://measure.infopop.cc/eve/forums

Int eh “Newer Measurers Questions and Information” section there is a forum for “Drawing 
Certification Maps.”  First read the questions others have asked, since someone may have already 
asked your question.  If you don't find the answer to your question, then create a new thread and ask.

http://measure.infopop.cc/eve/forums

